Dein Server läuft mit der PHP-Version 4.3.10-16, aber WordPress 3.4.2 benötigt mindestens die Version 5.2.4.